Win10下Python 2.7与Python 3.7双环境安装教程图解

Win10下python 2.7与python 3.7双环境安装教程,具体内容如下所示:

1、python软件下载网址:

https://www.python.org/downloads/windows/

6AA3E052-D71E-A8D2-15F1-70395A707659.jpeg

2、 安装python2.7.16

第一步双击安装包,选择你要安装的路径

第二步默认next,这里不能配置环境变量,只能安装好后手动配。

点击finish安装完成。这样python2和python3都已经安装好了。

3、安装python3.7.4

建议不要安装在系统盘,可以安装在D盘,建一个Python的目录,里面再建两个文件夹python2.7和python3.7。

第一步选择自定义安装,并且勾选Add Python3.7 to PATH,然后next

第二步直接默认next即可

第三步勾选install for all users,如果你以后打算在VS 2015中配置python环境请勾选Download debug binaris,点击install开始安装。

安装成功页面,关闭即可。

cmd打开命令提示符,输入python查看python3安装情况,显示python 3.7.2 的版本信息,则安装成功。

此时可以从开始那找到python3的IDLE,这个Python自带的工具对初学者调试代码还是很好用的。因为代码可以一行一行去调试,哪一行有问题马上就能看的出来。

4.添加python2和python3到系统环境变量

步骤:此电脑→属性→高级系统设置→高级→环境变量→系统变量(S)→选中Path,点击编辑→选择新建→新建两个,D:\Python\python27和D:\Python\python27\Scripts

这样环境变量就配好了。

此时可以看到配置好的环境变量如下:

9A64A1A0-A7D5-9AD6-8A77-92EFD6A92D88.jpeg

5、修改python.exe名字为python2.exe和python3.exe

去安装目录下修改即可。

此时需要注意Python2.7和Python3.6的可执行文件都是python.exe,需要加以区分:

首先是Python2.7,需要将其python.exe重命名为python2.exe:

这时,再调用Python2.7的话需要使用python2命令来区分:

其次是Python3.7,需要将其python.exe重命名为python3.exe:

这时,再调用Python3.7的话需要使用python3命令来区分:

修改完成后cmd打开命令提示符,

输入python2 -V显示python2.7.16版本,

输入python3 -V显示3.7.4版本。

至此,python2和python3 安装完毕。

6.最关键的一步来了。

pip2 和 pip3设置

python中很重要的一个工具就是pip包管理工具,有时候安装新的模块\包都要用到,所以我们要把python2和python3的pip区分开来,使得两个python版本的pip能够共存。

在cmd命令框输入命令,python3 -m pip install --upgrade pip --force-reinstall,显示重新安装成功。

在cmd命令框输入命令,python2 -m pip install --upgrade pip --force-reinstall,显示重新安装成功。

现在可以通过pip2 -V 和 pip3 -V 查看两个版本的pip信息,以后只需运行pip2 install XXX和pip3 install XXX即可安装各自的python包。

8DC4C169-695D-B2A3-41E3-8F9F227FC5F4.jpeg

BD73FC0A-207B-A567-72AD-63E56667AD2C.jpeg

D19D1A40-B923-FC23-760A-662AD5799B7B.jpeg

至此,Python2.7与Python3.7双环境共存设置完毕

7、向pycharm中导入project interpreter

安装后新建项目时遇到一个小问题,import 不能导入扩展包,File->Settings->Project->Project Interpreter 一定要选择正确的python编译器路径,这样python扩展包就自动加进去了。

05D8D731-7339-9F27-13B0-291ADA350328.jpeg

参考:https://www.jianshu.com/p/e30c52f27dad

https://baijiahao.baidu.com/s?id=1607774325597619048&wfr=spider&for=pc

8、出现:Microsoft Visual C++ 14.0 is required 的解决方案

error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools":http://landinghub.visualstudio.com/visual-cpp-build-tools

下面以安装scrapy为例:

如:pip install scrapy 时出现:

error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”: http://landinghub.visualstudio.com/visual-cpp-build-tools

解决办法

1)、安装 Microsoft visual c++ 14.0

https://964279924.ctfile.com/fs/1445568-239446865

https://pan.baidu.com/s/1q2Nj41Xk85CHHv7_zOhQIA 密码:qbba

2)、如果出现了.Net framework版本过低,小于4.5的最低版本要求:

[如果没出现这个问题,跳过这一步]

重新安装 .Net framework 更高的版本:

https://support.microsoft.com/en-us/help/3151800/the-net-framework-4-6-2-offline-installer-for-windows

再安装Microsoft visual c++ 14.0,

D96224D8-93DA-534A-0187-188D5465C15E.jpeg

9、出现AttributeError: 'MSVCCompiler' object has no attribute 'linker_exe'的解决办法

I'm trying to install AirFlow, but keep getting an error. The line - pip install apache-airflow

I installed Visual Studio with the proper packages, installed misaka, and updated both pip install version and setuptools.

56ABF1CD-86F3-2CC1-F0F7-D76B5FAAFAA9.jpeg

解决办法:

I had the same issue. Seems like airflow 1.10.4 has a new dependency on "dumb-init" which doesn't work well on Windows.

Install Airflow 1.10.3 worked fine for me.

pip install apache-airflow[postgres]==1.10.3

shareimprove this answer

参考:https://stackoverflow.com/questions/57466782/attributeerror-msvccompiler-object-has-no-attribute-linker-exe

10、依赖包版本太低解决方案:

C72B65AA-1CAF-C73A-3F81-2CCABBE38FA9.jpeg

收藏 (0)
评论列表
正在载入评论列表...
我是有底线的